Cisco WIC-1ADSL config for 1800 series router and ios 12.4

This config is for the Cisco 1800 series router running IOS 12.4. IOS 12.4 has some command and syntax changes in reguards to interfaces and configuration commands for PPPOE. This config was submitted by my good friend Pedro Rivera.

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

!

!

ip name-server 205.152.144.23

!

!

interface FastEthernet0/0

 description Internal Lan

 ip address 10.10.10.254 255.255.255.0

 ip nat inside

 ip virtual-reassembly

 ip tcp adjust-mss 1452

 duplex auto

 speed auto

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface ATM0/0/0

 no ip address

 no atm ilmi-keepalive

 dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point

 pvc 8/35

  pppoe-client dial-pool-number 1

 !

!

interface Dialer0

 ip address negotiated

 ip mtu 1452

 ip nat outside

 ip virtual-reassembly

 encapsulation ppp

 dialer pool 1

 dialer-group 1

 ppp authentication chap callin

 ppp chap hostname xxxxxxxxxxxxx@xxxxxxxxxxxxxx.net

 ppp chap password 0 xxxxxxxxxxxxxxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 remark INSIDE_IF=FastEthernet0/0

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 10.10.10.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

 login
111